Skip to content

← Actionable
Critical, CVSS 9.3amended

Cross-site scripting in Swagger-UI

CVE-2019-17495GHSA-c427-hjc3-wrfw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.springfox:springfox-swagger-ui 2.10.0; org.webjars:swagger-ui 3.23.11; org.webjars.npm:swagger-ui 3.23.11; swagger-ui 3.23.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2019-17495: 5.73% estimated exploitation activity in the next 30 days; percentile 93.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Cascading Style Sheets (CSS) injection vulnerability in Swagger UI before 3.23.11 allows attackers to use the Relative Path Overwrite (RPO) technique to perform CSS-based input field value exfiltration, such as exfiltration of a CSRF token value. In other words, this product intentionally allows the embedding of untrusted JSON data from remote servers, but it was not previously known that <style@import within the JSON data was a functional attack method.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c427-hjc3-wrfw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c427-hjc3-wrfw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-17495

Advisory: Cross-site scripting in Swagger-UI
IDs: CVE-2019-17495, GHSA-c427-hjc3-wrfw
Record: https://patchnext.com/advisories/cve-2019-17495 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.springfox:springfox-swagger-ui 2.10.0; org.webjars:swagger-ui 3.23.11; org.webjars.npm:swagger-ui 3.23.11; swagger-ui 3.23.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.springfox:springfox-swagger-ui: affected < 2.10.0; fixed in 2.10.0
- Maven org.webjars:swagger-ui: affected < 3.23.11; fixed in 3.23.11
- Maven org.webjars.npm:swagger-ui: affected < 3.23.11; fixed in 3.23.11
- npm swagger-ui: affected < 3.23.11; fixed in 3.23.11

## Suggested inspection (read-only)
- Maven io.springfox:springfox-swagger-ui: check the installed version with your package manager.
- Maven org.webjars:swagger-ui: check the installed version with your package manager.
- Maven org.webjars.npm:swagger-ui: check the installed version with your package manager.
- `npm ls swagger-ui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.springfox:springfox-swagger-ui, org.webjars:swagger-ui, org.webjars.npm:swagger-ui, swagger-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c427-hjc3-wrfw (OSV record GHSA-c427-hjc3-wrfw lists affected ranges: npm swagger-ui >=0 =0 =0 =0 <2.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-c427-hjc3-wrfw (GitHub-reviewed advisory GHSA-c427-hjc3-wrfw lists affected ranges: npm swagger-ui >=0 =0 =0 =0 <2.10.0)

Commands are suggestions: review each one before running it.

Loading voting…