Incorrect Authorization in runc
CVE-2019-16884GHSA-fgv8-vj5c-2ppq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/opencontainers/runc 1.0.0-rc8.0.20190930145003-cad42f6e0932; github.com/opencontainers/selinux 1.3.1-0.20190929122143-5215b1806f52), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/opencontainers/runc
- Affected
- < 1.0.0-rc8.0.20190930145003-cad42f6e0932
- Fixed in
- 1.0.0-rc8.0.20190930145003-cad42f6e0932
Go github.com/opencontainers/selinux
- Affected
- < 1.3.1-0.20190929122143-5215b1806f52
- Fixed in
- 1.3.1-0.20190929122143-5215b1806f52
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fgv8-vj5c-2ppq lists affected ranges: Go github.com/opencontainers/runc >=0 =0 <1.3.1-0.20190929122143-5215b1806f52
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2019-16884: 4.41% estimated exploitation activity in the next 30 days; percentile 91.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
runc through 1.0.0-rc8, as used in Docker through 19.03.2-ce and other products, allows AppArmor restriction bypass because libcontainer/rootfslinux.go incorrectly checks mount targets, and thus a malicious Docker image can mount over a /proc directory.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fgv8-vj5c-2ppq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16884 Advisory: Incorrect Authorization in runc IDs: CVE-2019-16884, GHSA-fgv8-vj5c-2ppq Record: https://patchnext.com/advisories/cve-2019-16884 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/opencontainers/runc 1.0.0-rc8.0.20190930145003-cad42f6e0932; github.com/opencontainers/selinux 1.3.1-0.20190929122143-5215b1806f52. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/opencontainers/runc: affected < 1.0.0-rc8.0.20190930145003-cad42f6e0932; fixed in 1.0.0-rc8.0.20190930145003-cad42f6e0932 - Go github.com/opencontainers/selinux: affected < 1.3.1-0.20190929122143-5215b1806f52; fixed in 1.3.1-0.20190929122143-5215b1806f52 ## Suggested inspection (read-only) - Go github.com/opencontainers/runc: check the installed version with your package manager. - Go github.com/opencontainers/selinux: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/opencontainers/runc, github.com/opencontainers/selinux. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fgv8-vj5c-2ppq (GitHub-reviewed advisory GHSA-fgv8-vj5c-2ppq lists affected ranges: Go github.com/opencontainers/runc >=0 =0 <1.3.1-0.20190929122143-5215b1806f52) Commands are suggestions: review each one before running it.
Loading voting…