Skip to content

← Actionable
High, CVSS 7.5

Use after free in string-interner

CVE-2019-16882GHSA-49fq-pw77-6qxj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (string-interner 0.7.1, 0.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io string-interner

    Affected
    >= 0.7.0, < 0.7.1< 0.6.4
    Fixed in
    0.6.4, 0.7.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2019-16882: 1.55% estimated exploitation activity in the next 30 days; percentile 75.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of this crate did not clone contained strings when an interner is cloned. Interners have raw pointers to the contained strings, and they keep pointing the strings which the old interner owns, after the interner is cloned. If a new cloned interner is alive and the old original interner is dead, the new interner has dangling pointers to the old interner's storage, which is already dropped. This allows an attacker to read the already freed memory. The dangling pointers are used by the interners to check a string is already interned. An attacker can do brute force attack to get the data pointed by the dangling pointer.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-49fq-pw77-6qxj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-16882

Advisory: Use after free in string-interner
IDs: CVE-2019-16882, GHSA-49fq-pw77-6qxj
Record: https://patchnext.com/advisories/cve-2019-16882 (revision 1, source checked 26 Oct 2026, 15:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: string-interner 0.7.1, 0.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io string-interner: affected >= 0.7.0, < 0.7.1; < 0.6.4; fixed in 0.6.4, 0.7.1

## Suggested inspection (read-only)
- crates.io string-interner: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on string-interner.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-49fq-pw77-6qxj (GitHub-reviewed advisory GHSA-49fq-pw77-6qxj lists affected ranges: crates.io string-interner >=0.7.0 =0 <0.6.4)

Commands are suggestions: review each one before running it.

Loading voting…