Use after free in portaudio-rs
CVE-2019-16881GHSA-qpjr-ch72-2qq4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (portaudio-rs 0.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io portaudio-rs
- Affected
- < 0.3.2
- Fixed in
- 0.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qpjr-ch72-2qq4 lists affected ranges: crates.io portaudio-rs >=0 <0.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-16881: 2.51% estimated exploitation activity in the next 30 days; percentile 84.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of this crate is not panic safe within callback functions streamcallback and streamfinishedcallback. The call to user-provided closure might panic before a mem::forget call, which then causes a use after free that grants attacker to control the callback function pointer. This allows an attacker to construct an arbitrary code execution .
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qpjr-ch72-2qq4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16881 Advisory: Use after free in portaudio-rs IDs: CVE-2019-16881, GHSA-qpjr-ch72-2qq4 Record: https://patchnext.com/advisories/cve-2019-16881 (revision 1, source checked 26 Oct 2026, 15:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: portaudio-rs 0.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io portaudio-rs: affected < 0.3.2; fixed in 0.3.2 ## Suggested inspection (read-only) - crates.io portaudio-rs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on portaudio-rs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qpjr-ch72-2qq4 (GitHub-reviewed advisory GHSA-qpjr-ch72-2qq4 lists affected ranges: crates.io portaudio-rs >=0 <0.3.2) Commands are suggestions: review each one before running it.
Loading voting…