HTTP Request Smuggling: Content-Length Sent Twice in Waitress
CVE-2019-16792GHSA-4ppp-gpcr-7qf6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (waitress 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI waitress
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4ppp-gpcr-7qf6 lists affected ranges: PyPI waitress >=0 <1.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2019-16792: 1.98% estimated exploitation activity in the next 30 days; percentile 80.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Waitress would header fold a double `Content-Length` header and due to being unable to cast the now comma separated value to an integer would set the `Content-Length` to 0 internally. So a request with: ``` Content-Length: 10 Content-Length: 10 ``` would get transformed to: ``` Content-Length: 10, 10 ``` Which would Waitress would then internally set to `Content-Lenght: 0`. Waitress would then treat the request as having no body, thereby treating the body of the request as a new request in HTTP pipelining.
Patches This issue is fixed in Waitress 1.4.0. This brings a range of changes to harden Waitress against potential HTTP request confusions, and may change the behaviour of Waitress behind non-conformist proxies. The Pylons Project recommends upgrading as soon as possible, while validating that the changes in Waitress don't cause any changes in behavior.
Workarounds Various reverse proxies may have protections against sending potentially bad HTTP requests to the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GHSA-4ppp-gpcr-7qf6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16792 Advisory: HTTP Request Smuggling: Content-Length Sent Twice in Waitress IDs: CVE-2019-16792, GHSA-4ppp-gpcr-7qf6 Record: https://patchnext.com/advisories/cve-2019-16792 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: waitress 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI waitress: affected < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - `python -m pip show waitress`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on waitress. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4ppp-gpcr-7qf6 (OSV record GHSA-4ppp-gpcr-7qf6 lists affected ranges: PyPI waitress >=0 <1.4.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…