Skip to content

← Actionable
Medium, CVSS 5.1amended

HTTP Request Smuggling: Invalid Transfer-Encoding in Waitress

CVE-2019-16786GHSA-g2xc-35jw-c63p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (waitress 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI waitress

    Affected
    < 1.4.0
    Fixed in
    1.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N · score source
EPSS
  • CVE-2019-16786: 2.38% estimated exploitation activity in the next 30 days; percentile 83.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Waitress would parse the Transfer-Encoding header and only look for a single string value, if that value was not chunked it would fall through and use the Content-Length header instead. According to the HTTP standard Transfer-Encoding should be a comma separated list, with the inner-most encoding first, followed by any further transfer codings, ending with chunked. Requests sent with: Would incorrectly get ignored, and the request would use a Content-Length header instead to determine the body size of the HTTP message. This could allow for Waitress to treat a single request as multiple requests in the case of HTTP pipelining. Patches This issue is fixed in Waitress 1.4.0. This brings a range of changes to harden Waitress against potential HTTP request confusions, and may change the behaviour of Waitress behind non-conformist proxies. Waitress will now return a 501 Not Implemented error if the Transfer-Encoding is not chunked or contains multiple elements. Waitress does not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g2xc-35jw-c63p

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-g2xc-35jw-c63p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-16786

Advisory: HTTP Request Smuggling: Invalid Transfer-Encoding in Waitress
IDs: CVE-2019-16786, GHSA-g2xc-35jw-c63p
Record: https://patchnext.com/advisories/cve-2019-16786 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: waitress 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI waitress: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `python -m pip show waitress`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on waitress.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g2xc-35jw-c63p (OSV record GHSA-g2xc-35jw-c63p lists affected ranges: PyPI waitress >=0 <1.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g2xc-35jw-c63p (GitHub-reviewed advisory GHSA-g2xc-35jw-c63p lists affected ranges: PyPI waitress >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…