HTTP Request Smuggling: LF vs CRLF handling in Waitress
CVE-2019-16785GHSA-pg36-wpm5-g57p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (waitress 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI waitress
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pg36-wpm5-g57p lists affected ranges: PyPI waitress >=0 <1.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pg36-wpm5-g57p lists affected ranges: PyPI waitress >=0 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N · score source
- EPSS
- CVE-2019-16785: 2.54% estimated exploitation activity in the next 30 days; percentile 84.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Waitress implemented a &quot;MAY&quot; part of the RFC7230 (https://tools.ietf.org/html/rfc7230#section-3.5) which states: Although the line terminator for the start-line and header fields is the sequence CRLF, a recipient MAY recognize a single LF as a line terminator and ignore any preceding CR. Unfortunately if a front-end server does not parse header fields with an LF the same way as it does those with a CRLF it can lead to the front-end and the back-end server parsing the same HTTP message in two different ways. This can lead to a potential for HTTP request smuggling/splitting whereby Waitress may see two requests while the front-end server only sees a single HTTP message. Example: Would get treated by Waitress as if it were: This could potentially get used by attackers to split the HTTP request and smuggle a second request in the body of the first. Patches This issue is fixed in Waitress 1.4.0. This brings a range of changes to harden Waitress against potential…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pg36-wpm5-g57p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pg36-wpm5-g57p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16785 Advisory: HTTP Request Smuggling: LF vs CRLF handling in Waitress IDs: CVE-2019-16785, GHSA-pg36-wpm5-g57p Record: https://patchnext.com/advisories/cve-2019-16785 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: waitress 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI waitress: affected < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - `python -m pip show waitress`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on waitress. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pg36-wpm5-g57p (OSV record GHSA-pg36-wpm5-g57p lists affected ranges: PyPI waitress >=0 <1.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-pg36-wpm5-g57p (GitHub-reviewed advisory GHSA-pg36-wpm5-g57p lists affected ranges: PyPI waitress >=0 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…