Skip to content

← Actionable
Medium, CVSS 6.3

Possible Information Leak / Session Hijack Vulnerability in Rack

CVE-2019-16782GHSA-hrqr-hxpp-chr3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 2.0.8, 1.6.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rack

    Affected
    < 1.6.12>= 2.0.0, < 2.0.8
    Fixed in
    2.0.8, 1.6.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2019-16782: 3.70% estimated exploitation activity in the next 30 days; percentile 89.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There's a possible information leak / session hijack vulnerability in Rack. Attackers may be able to find and hijack sessions by using timing attacks targeting the session id. Session ids are usually stored and indexed in a database that uses some kind of scheme for speeding up lookups of that session id. By carefully measuring the amount of time it takes to look up a session, an attacker may be able to find a valid session id and hijack the session. The session id itself may be generated randomly, but the way the session is indexed by the backing store does not use a secure comparison. Impact The session id stored in a cookie is the same id that is used when querying the backing session storage engine. Most storage mechanisms (for example a database) use some sort of indexing in order to speed up the lookup of that id. By carefully timing requests and session lookup failures, an attacker may be able to perform a timing attack to determine an existing session id and hijack that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hrqr-hxpp-chr3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-16782

Advisory: Possible Information Leak / Session Hijack Vulnerability in Rack
IDs: CVE-2019-16782, GHSA-hrqr-hxpp-chr3
Record: https://patchnext.com/advisories/cve-2019-16782 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rack 2.0.8, 1.6.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rack: affected < 1.6.12; >= 2.0.0, < 2.0.8; fixed in 2.0.8, 1.6.12

## Suggested inspection (read-only)
- RubyGems rack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hrqr-hxpp-chr3 (GitHub-reviewed advisory GHSA-hrqr-hxpp-chr3 lists affected ranges: RubyGems rack >=0 =2.0.0 <2.0.8)

Commands are suggestions: review each one before running it.

Loading voting…