In RubyGem excon, interrupted Persistent Connections May Leak Response Data
CVE-2019-16779GHSA-q58g-455p-8vw9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (excon 0.71.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems excon
- Affected
- < 0.71.0
- Fixed in
- 0.71.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q58g-455p-8vw9 lists affected ranges: RubyGems excon >=0 <0.71.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N
- EPSS
- CVE-2019-16779: 1.66% estimated exploitation activity in the next 30 days; percentile 76.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There was a race condition around persistent connections, where a connection which is interrupted (such as by a timeout) would leave data on the socket. Subsequent requests would then read this data, returning content from the previous response. The race condition window appears to be short, and it would be difficult to purposefully exploit this. Patches The problem has been patched in 0.71.0, users should upgrade to this or a newer version (if one exists). Workarounds Users can workaround the problem by disabling persistent connections, though this may cause performance implications. References See the patch for further details. For more information If you have any questions or comments about this advisory: Open an issue in excon/issues Email us at geemus+github@gmail.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q58g-455p-8vw9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16779 Advisory: In RubyGem excon, interrupted Persistent Connections May Leak Response Data IDs: CVE-2019-16779, GHSA-q58g-455p-8vw9 Record: https://patchnext.com/advisories/cve-2019-16779 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: excon 0.71.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems excon: affected < 0.71.0; fixed in 0.71.0 ## Suggested inspection (read-only) - RubyGems excon: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on excon. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q58g-455p-8vw9 (GitHub-reviewed advisory GHSA-q58g-455p-8vw9 lists affected ranges: RubyGems excon >=0 <0.71.0) Commands are suggestions: review each one before running it.
Loading voting…