Cross-Site Scripting in serialize-javascript
CVE-2019-16769GHSA-h9rv-jmmf-4pgx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (serialize-javascript 2.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.1.1
- Fixed in
- 2.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h9rv-jmmf-4pgx lists affected ranges: npm serialize-javascript >=0 <2.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h9rv-jmmf-4pgx lists affected ranges: npm serialize-javascript >=0 <2.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2019-16769: 0.80% estimated exploitation activity in the next 30 days; percentile 56.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of serialize-javascript prior to 2.1.1 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize serialized regular expressions. This vulnerability does not affect Node.js applications. Recommendation Upgrade to version 2.1.1 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h9rv-jmmf-4pgx
- Revision 1 · created ·
Published from osv record GHSA-h9rv-jmmf-4pgx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16769 Advisory: Cross-Site Scripting in serialize-javascript IDs: CVE-2019-16769, GHSA-h9rv-jmmf-4pgx Record: https://patchnext.com/advisories/cve-2019-16769 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: serialize-javascript 2.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm serialize-javascript: affected < 2.1.1; fixed in 2.1.1 ## Suggested inspection (read-only) - `npm ls serialize-javascript --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on serialize-javascript. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h9rv-jmmf-4pgx (OSV record GHSA-h9rv-jmmf-4pgx lists affected ranges: npm serialize-javascript >=0 <2.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-h9rv-jmmf-4pgx (GitHub-reviewed advisory GHSA-h9rv-jmmf-4pgx lists affected ranges: npm serialize-javascript >=0 <2.1.1) Commands are suggestions: review each one before running it.
Loading voting…