Skip to content

← Actionable
Low, CVSS 3.5

Internal exception message exposure for login action in Sylius

CVE-2019-16768GHSA-3r8j-pmch-5j2h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/sylius 1.6.3, 1.5.7, 1.4.10, 1.3.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist sylius/sylius

    Affected
    < 1.3.14>= 1.4.0, < 1.4.10>= 1.5.0, < 1.5.7>= 1.6.0, < 1.6.3
    Fixed in
    1.6.3, 1.4.10, 1.3.14, 1.5.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2019-16768: 0.75% estimated exploitation activity in the next 30 days; percentile 54.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Internal exception message exposure for login action Impact Exception messages from internal exceptions (like database exception) are wrapped by \Symfony\Component\Security\Core\Exception\AuthenticationServiceException and propagated through the system to UI. Therefore, some internal system information may leak and be visible to the customer. A validation message with the exception details will be presented to the user when one will try to log into the shop. Patches Has the problem been patched? What versions should users upgrade to? Workarounds The src/Sylius/Bundle/UiBundle/Resources/views/Security/login.html.twig file should be overridden and lines https://github.com/Sylius/Sylius/blob/1.4/src/Sylius/Bundle/UiBundle/Resources/views/Security/login.html.twig#L13-L17 should be replaced with The messageKey field should be used instead of the message.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3r8j-pmch-5j2h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-16768

Advisory: Internal exception message exposure for login action in Sylius
IDs: CVE-2019-16768, GHSA-3r8j-pmch-5j2h
Record: https://patchnext.com/advisories/cve-2019-16768 (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sylius/sylius 1.6.3, 1.5.7, 1.4.10, 1.3.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist sylius/sylius: affected < 1.3.14; >= 1.4.0, < 1.4.10; >= 1.5.0, < 1.5.7; >= 1.6.0, < 1.6.3; fixed in 1.6.3, 1.4.10, 1.3.14, 1.5.7

## Suggested inspection (read-only)
- Packagist sylius/sylius: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sylius/sylius.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3r8j-pmch-5j2h (GitHub-reviewed advisory GHSA-3r8j-pmch-5j2h lists affected ranges: Packagist sylius/sylius >=0 =1.4.0 =1.5.0 =1.6.0 <1.6.3)

Commands are suggestions: review each one before running it.

Loading voting…