2FA bypass in Wagtail through new device path
CVE-2019-16766GHSA-89px-ww3j-g2mm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail-2fa 1.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wagtail-2fa
- Affected
- < 1.3.0
- Fixed in
- 1.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-89px-ww3j-g2mm lists affected ranges: PyPI wagtail-2fa >=0 <1.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-89px-ww3j-g2mm lists affected ranges: PyPI wagtail-2fa >=0 <1.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2019-16766: 1.46% estimated exploitation activity in the next 30 days; percentile 73.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
2FA bypass through new device path Impact If someone gains access to someone's Wagtail login credentials, they can log into the CMS and bypass the 2FA check by changing the URL. They can then add a new device and gain full access to the CMS. Patches This problem has been patched in version 1.3.0. Workarounds There is no workaround at the moment. For more information If you have any questions or comments about this advisory: Open an issue in github.com/labd/wagtail-2fa Email us at security@labdigital.nl
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-89px-ww3j-g2mm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-89px-ww3j-g2mm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16766 Advisory: 2FA bypass in Wagtail through new device path IDs: CVE-2019-16766, GHSA-89px-ww3j-g2mm Record: https://patchnext.com/advisories/cve-2019-16766 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wagtail-2fa 1.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wagtail-2fa: affected < 1.3.0; fixed in 1.3.0 ## Suggested inspection (read-only) - `python -m pip show wagtail-2fa`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wagtail-2fa. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-89px-ww3j-g2mm (OSV record GHSA-89px-ww3j-g2mm lists affected ranges: PyPI wagtail-2fa >=0 <1.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-89px-ww3j-g2mm (GitHub-reviewed advisory GHSA-89px-ww3j-g2mm lists affected ranges: PyPI wagtail-2fa >=0 <1.3.0) Commands are suggestions: review each one before running it.
Loading voting…