Pannellum Cross-Site Scripting due to data not being sanitized for URIs or vbscript
CVE-2019-16763GHSA-m52x-29pq-w3vv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pannellum 2.5.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pannellum
- Affected
- >= 2.5.0, < 2.5.5
- Fixed in
- 2.5.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m52x-29pq-w3vv lists affected ranges: npm pannellum >=2.5.0 <2.5.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m52x-29pq-w3vv lists affected ranges: npm pannellum >=2.5.0 <2.5.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2019-16763: 0.70% estimated exploitation activity in the next 30 days; percentile 53.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of pannellum prior to 2.5.6 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize URLs for data URIs, which may allow attackers to execute arbitrary code in a victim's browser. Recommendation Upgrade to version 2.5.6 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m52x-29pq-w3vv
- Revision 1 · created ·
Published from osv record GHSA-m52x-29pq-w3vv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16763 Advisory: Pannellum Cross-Site Scripting due to data not being sanitized for URIs or vbscript IDs: CVE-2019-16763, GHSA-m52x-29pq-w3vv Record: https://patchnext.com/advisories/cve-2019-16763 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pannellum 2.5.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pannellum: affected >= 2.5.0, < 2.5.5; fixed in 2.5.5 ## Suggested inspection (read-only) - `npm ls pannellum --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pannellum. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m52x-29pq-w3vv (OSV record GHSA-m52x-29pq-w3vv lists affected ranges: npm pannellum >=2.5.0 <2.5.5 (fixed)) - Verified: https://github.com/advisories/GHSA-m52x-29pq-w3vv (GitHub-reviewed advisory GHSA-m52x-29pq-w3vv lists affected ranges: npm pannellum >=2.5.0 <2.5.5) Commands are suggestions: review each one before running it.
Loading voting…