Skip to content

← Actionable
Medium, CVSS 5.7amended

Critical severity vulnerability that affects slpjs

CVE-2019-16762GHSA-425c-ccf3-3jrr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (slpjs 0.21.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm slpjs

    Affected
    < 0.21.4
    Fixed in
    0.21.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.7 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
EPSS
  • CVE-2019-16762: 1.10% estimated exploitation activity in the next 30 days; percentile 65.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Validator parsing discrepancy due to string encoding Impact A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Patches All versions 0.21.3 are patched. Workarounds Upgrade to any version = 0.21.4. References The bug was located and fixed here. For more information If you have any questions or comments about this advisory: Open an issue in the slpjs repo Email us at info@slp.cash

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-425c-ccf3-3jrr

  2. Revision 1 · created ·

    Published from osv record GHSA-425c-ccf3-3jrr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-16762

Advisory: Critical severity vulnerability that affects slpjs
IDs: CVE-2019-16762, GHSA-425c-ccf3-3jrr
Record: https://patchnext.com/advisories/cve-2019-16762 (revision 2, source checked 26 Oct 2026, 12:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: slpjs 0.21.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm slpjs: affected < 0.21.4; fixed in 0.21.4

## Suggested inspection (read-only)
- `npm ls slpjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on slpjs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-425c-ccf3-3jrr (OSV record GHSA-425c-ccf3-3jrr lists affected ranges: npm slpjs >=0 <0.21.4 (fixed))
- Verified: https://github.com/advisories/GHSA-425c-ccf3-3jrr (GitHub-reviewed advisory GHSA-425c-ccf3-3jrr lists affected ranges: npm slpjs >=0 <0.21.4)

Commands are suggestions: review each one before running it.

Loading voting…