Skip to content

← Actionable
Medium, CVSS 5.7amended

Validation Bypass in slp-validate

CVE-2019-16761GHSA-wmx6-vxcf-c3gr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (slp-validate 1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.7 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
EPSS
  • CVE-2019-16761: 0.99% estimated exploitation activity in the next 30 days; percentile 62.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of slp-validate prior to 1.0.1 are vulnerable to a validation bypass. Bitcoin scripts may cause the validation result from slp-validate to differ from the specified SLP consensus. This allows an attacker to create a Bitcoin script that causes a hard-fork from the SLP consensus. Recommendation Upgrade to version 1.0.1 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wmx6-vxcf-c3gr

  2. Revision 1 · created ·

    Published from osv record GHSA-wmx6-vxcf-c3gr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-16761

Advisory: Validation Bypass in slp-validate
IDs: CVE-2019-16761, GHSA-wmx6-vxcf-c3gr
Record: https://patchnext.com/advisories/cve-2019-16761 (revision 2, source checked 26 Oct 2026, 12:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: slp-validate 1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm slp-validate: affected >= 1.0.0, <= 1.0.0; fixed in 1.0.1

## Suggested inspection (read-only)
- `npm ls slp-validate --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on slp-validate.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wmx6-vxcf-c3gr (OSV record GHSA-wmx6-vxcf-c3gr lists affected ranges: npm slp-validate >=1.0.0 <1.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-wmx6-vxcf-c3gr (GitHub-reviewed advisory GHSA-wmx6-vxcf-c3gr lists affected ranges: npm slp-validate >=1.0.0 <=1.0.0)

Commands are suggestions: review each one before running it.

Loading voting…