Skip to content

← Actionable
Medium, CVSS 5.3

MediaWiki information disclosure

CVE-2019-16738GHSA-7hwr-f745-5rwq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mediawiki/core 1.33.1, 1.32.4, 1.31.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mediawiki/core

    Affected
    >= 1.31.0, < 1.31.4>= 1.32.0, < 1.32.4>= 1.33.0, < 1.33.1
    Fixed in
    1.33.1, 1.31.4, 1.32.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2019-16738: 1.77% estimated exploitation activity in the next 30 days; percentile 78.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In MediaWiki through 1.33.0, Special:Redirect allows information disclosure of suppressed usernames via a User ID Lookup.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7hwr-f745-5rwq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-16738

Advisory: MediaWiki information disclosure
IDs: CVE-2019-16738, GHSA-7hwr-f745-5rwq
Record: https://patchnext.com/advisories/cve-2019-16738 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mediawiki/core 1.33.1, 1.32.4, 1.31.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mediawiki/core: affected >= 1.31.0, < 1.31.4; >= 1.32.0, < 1.32.4; >= 1.33.0, < 1.33.1; fixed in 1.33.1, 1.31.4, 1.32.4

## Suggested inspection (read-only)
- Packagist mediawiki/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mediawiki/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7hwr-f745-5rwq (GitHub-reviewed advisory GHSA-7hwr-f745-5rwq lists affected ranges: Packagist mediawiki/core >=1.31.0 =1.32.0 =1.33.0 <1.33.1)

Commands are suggestions: review each one before running it.

Loading voting…