Improper Input Validation in simple_form
CVE-2019-16676GHSA-r74q-gxcg-73hx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simple_form 5.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems simple_form
- Affected
- < 5.0.0
- Fixed in
- 5.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r74q-gxcg-73hx lists affected ranges: RubyGems simple_form >=0 <5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-16676: 3.40% estimated exploitation activity in the next 30 days; percentile 88.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Incorrect Access Control in filemethod? in lib/simpleform/formbuilder.rb; a user-supplied string is invoked as a method call Impact For pages that build a form using user input, it is possible for an attacker to manipulate the input and send any method present in the form object. For example: The string provided in the variable @usersuppliedstring would be invoked as a method call inside the @user object (unless the string contains any of the following: password, timezone, country, email, phone and url). By manipulation that input, an attacker could do any of the following: - Code execution (call actions like #destroy) - Denial of Service (by executing a computation intensive method) - Information Disclosure (check the presence of methods, leak user information) Patches The problem was fixed in version 5.0. Although it's a major version, there should be no issues with upgrading for 4.x. The reason it was released in a major version is that the configuration SimpleForm.filemethods was…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r74q-gxcg-73hx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16676 Advisory: Improper Input Validation in simple_form IDs: CVE-2019-16676, GHSA-r74q-gxcg-73hx Record: https://patchnext.com/advisories/cve-2019-16676 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simple_form 5.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems simple_form: affected < 5.0.0; fixed in 5.0.0 ## Suggested inspection (read-only) - RubyGems simple_form: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simple_form. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r74q-gxcg-73hx (GitHub-reviewed advisory GHSA-r74q-gxcg-73hx lists affected ranges: RubyGems simple_form >=0 <5.0.0) Commands are suggestions: review each one before running it.
Loading voting…