Jenkins Maven Release Plug-in Plugin XXE vulnerability
CVE-2019-16549GHSA-7mf5-79gv-66gh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins.m2release:m2release 0.16.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins.m2release:m2release
- Affected
- <= 0.16.1
- Fixed in
- 0.16.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7mf5-79gv-66gh lists affected ranges: Maven org.jenkins-ci.plugins.m2release:m2release >=0 <=0.16.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L
- EPSS
- CVE-2019-16549: 0.97% estimated exploitation activity in the next 30 days; percentile 61.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Maven Release Plug-in Plugin retrieves XML from Nexus repository manager APIs. Maven Release Plug-in Plugin 0.16.1 and earlier does not configure the XML parser to prevent XML external entity (XXE) attacks. While Jenkins users without Overall/Administer permission are not allowed to configure a custom Nexus URL, this could still be exploited via man-in-the-middle attacks, especially if it’s not an HTTPS URL. Additionally, a connection test form validation method does not require POST requests, resulting in a cross-site request forgery vulnerability. Combined, these two vulnerabilities allow attackers to have Jenkins parse crafted XML documents that use external entities for extraction of secrets from the Jenkins controller, server-side request forgery, or denial-of-service attacks. Maven Release Plug-in Plugin 0.16.2 configures its XML parser to prevent XML external entity (XXE) attacks. It also now requires that requests to the connection test form validation method are done…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7mf5-79gv-66gh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16549 Advisory: Jenkins Maven Release Plug-in Plugin XXE vulnerability IDs: CVE-2019-16549, GHSA-7mf5-79gv-66gh Record: https://patchnext.com/advisories/cve-2019-16549 (revision 1, source checked 26 Oct 2026, 16:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins.m2release:m2release 0.16.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins.m2release:m2release: affected <= 0.16.1; fixed in 0.16.2 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins.m2release:m2release: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins.m2release:m2release. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7mf5-79gv-66gh (GitHub-reviewed advisory GHSA-7mf5-79gv-66gh lists affected ranges: Maven org.jenkins-ci.plugins.m2release:m2release >=0 <=0.16.1) Commands are suggestions: review each one before running it.
Loading voting…