Skip to content

← Actionable
High, CVSS 7.2

Improper Input Validation in Centreon Web

CVE-2019-16405GHSA-4f26-v6fr-9hmp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (centreon/centreon 19.04.5, 18.10.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist centreon/centreon

    Affected
    < 18.10.8>= 19.0.0, < 19.04.5
    Fixed in
    19.04.5, 18.10.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-16405: 27.00% estimated exploitation activity in the next 30 days; percentile 98.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Centreon Web 19.04.4 allows Remote Code Execution by an administrator who can modify Macro Expression location settings.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4f26-v6fr-9hmp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-16405

Advisory: Improper Input Validation in Centreon Web
IDs: CVE-2019-16405, GHSA-4f26-v6fr-9hmp
Record: https://patchnext.com/advisories/cve-2019-16405 (revision 1, source checked 26 Oct 2026, 14:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: centreon/centreon 19.04.5, 18.10.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist centreon/centreon: affected < 18.10.8; >= 19.0.0, < 19.04.5; fixed in 19.04.5, 18.10.8

## Suggested inspection (read-only)
- Packagist centreon/centreon: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on centreon/centreon.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4f26-v6fr-9hmp (GitHub-reviewed advisory GHSA-4f26-v6fr-9hmp lists affected ranges: Packagist centreon/centreon >=0 =19.0.0 <19.04.5)

Commands are suggestions: review each one before running it.

Loading voting…