Dynamic modification of RPyC service due to missing security check
CVE-2019-16328GHSA-pj4g-4488-wmxm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rpyc 4.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI rpyc
- Affected
- >= 4.1.0, < 4.1.1
- Fixed in
- 4.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pj4g-4488-wmxm lists affected ranges: PyPI rpyc >=4.1.0 <4.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2019-16328: 13.05% estimated exploitation activity in the next 30 days; percentile 96.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Version 4.1.0 of RPyC has a vulnerability that affects custom RPyC services making it susceptible to authenticated remote attacks.
Patches Git commits between September 2018 and October 2019 and version 4.1.0 are vulnerable. Use a version of RPyC that is not affected.
Workarounds The commit `d818ecc83a92548994db75a0e9c419c7bce680d6` could be used as a patch to add the missing access check.
References CVE-2019-16328 RPyC Security Documentation
For more information If you have any questions or comments about this advisory: * Open an issue using GitHub
Proof of Concept ``` import logging import rpyc import tempfile from subprocess import Popen, PIPE import unittest PORT = 18861 SERVER_SCRIPT = f"""#!/usr/bin/env python import rpyc from rpyc.utils.server import ThreadedServer,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GHSA-pj4g-4488-wmxm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16328 Advisory: Dynamic modification of RPyC service due to missing security check IDs: CVE-2019-16328, GHSA-pj4g-4488-wmxm Record: https://patchnext.com/advisories/cve-2019-16328 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rpyc 4.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI rpyc: affected >= 4.1.0, < 4.1.1; fixed in 4.1.1 ## Suggested inspection (read-only) - `python -m pip show rpyc`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rpyc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pj4g-4488-wmxm (OSV record GHSA-pj4g-4488-wmxm lists affected ranges: PyPI rpyc >=4.1.0 <4.1.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…