Skip to content

← Actionable
High, CVSS 7.5

Improper Input Validation in once_cell

CVE-2019-16141GHSA-7j44-fv4x-79g9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (once_cell 1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io once_cell

    Affected
    >= 0.2.5, < 1.0.1
    Fixed in
    1.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2019-16141: 1.58% estimated exploitation activity in the next 30 days; percentile 75.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

If during the first dereference of Lazy the initialization function panics, subsequent dereferences will execute std::hints::unreachableunchecked. Applications with panic = "abort" are not affected, as there will be no subsequent dereferences.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7j44-fv4x-79g9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-16141

Advisory: Improper Input Validation in once_cell
IDs: CVE-2019-16141, GHSA-7j44-fv4x-79g9
Record: https://patchnext.com/advisories/cve-2019-16141 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: once_cell 1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io once_cell: affected >= 0.2.5, < 1.0.1; fixed in 1.0.1

## Suggested inspection (read-only)
- crates.io once_cell: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on once_cell.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7j44-fv4x-79g9 (GitHub-reviewed advisory GHSA-7j44-fv4x-79g9 lists affected ranges: crates.io once_cell >=0.2.5 <1.0.1)

Commands are suggestions: review each one before running it.

Loading voting…