Skip to content

← Actionable
Medium, CVSS 6.1

Cross-site Scripting in Grav

CVE-2019-16126GHSA-6268-v434-45m5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 1.7.0-beta.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getgrav/grav

    Affected
    <= 1.7.0-beta.7
    Fixed in
    1.7.0-beta.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-16126: 1.54% estimated exploitation activity in the next 30 days; percentile 74.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Grav through 1.6.15 allows (Stored) Cross-Site Scripting due to JavaScript execution in SVG images.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6268-v434-45m5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-16126

Advisory: Cross-site Scripting in Grav
IDs: CVE-2019-16126, GHSA-6268-v434-45m5
Record: https://patchnext.com/advisories/cve-2019-16126 (revision 1, source checked 26 Oct 2026, 14:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 1.7.0-beta.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getgrav/grav: affected <= 1.7.0-beta.7; fixed in 1.7.0-beta.8

## Suggested inspection (read-only)
- Packagist getgrav/grav: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getgrav/grav.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6268-v434-45m5 (GitHub-reviewed advisory GHSA-6268-v434-45m5 lists affected ranges: Packagist getgrav/grav >=0 <=1.7.0-beta.7)

Commands are suggestions: review each one before running it.

Loading voting…