Skip to content

← Actionable
High, CVSS 7.5

phpBB arbitrary CSS injection

CVE-2019-16108GHSA-8hc2-hvrc-x4qr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpbb/phpbb 3.2.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpbb/phpbb

    Affected
    >= 3.2.7, <= 3.2.7
    Fixed in
    3.2.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2019-16108: 1.08% estimated exploitation activity in the next 30 days; percentile 65.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8hc2-hvrc-x4qr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-16108

Advisory: phpBB arbitrary CSS injection
IDs: CVE-2019-16108, GHSA-8hc2-hvrc-x4qr
Record: https://patchnext.com/advisories/cve-2019-16108 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpbb/phpbb 3.2.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpbb/phpbb: affected >= 3.2.7, <= 3.2.7; fixed in 3.2.8

## Suggested inspection (read-only)
- Packagist phpbb/phpbb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpbb/phpbb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8hc2-hvrc-x4qr (GitHub-reviewed advisory GHSA-8hc2-hvrc-x4qr lists affected ranges: Packagist phpbb/phpbb >=3.2.7 <=3.2.7)

Commands are suggestions: review each one before running it.

Loading voting…