Cross-Site Scripting in webtorrent
CVE-2019-15782GHSA-gjh4-fcv3-whpq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (webtorrent 0.107.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm webtorrent
- Affected
- < 0.107.6
- Fixed in
- 0.107.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gjh4-fcv3-whpq lists affected ranges: npm webtorrent >=0 <0.107.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gjh4-fcv3-whpq lists affected ranges: npm webtorrent >=0 <0.107.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-15782: 1.47% estimated exploitation activity in the next 30 days; percentile 73.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of webtorrent prior to 0.107.6 are vulnerable to Cross-Site Scripting. webtorrent servers started with torrent.createServer() lists a torrent's title and files in the index page without sanitization. This allows attackers to execute arbitrary JavaScript in the victim's browser through files with names containing the malicious payload. The issue is mitigated due to the fact that the server only allows fetching data pieces from the torrent. Recommendation Upgrade to version 0.107.6 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gjh4-fcv3-whpq
- Revision 1 · created ·
Published from osv record GHSA-gjh4-fcv3-whpq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-15782 Advisory: Cross-Site Scripting in webtorrent IDs: CVE-2019-15782, GHSA-gjh4-fcv3-whpq Record: https://patchnext.com/advisories/cve-2019-15782 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: webtorrent 0.107.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm webtorrent: affected < 0.107.6; fixed in 0.107.6 ## Suggested inspection (read-only) - `npm ls webtorrent --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on webtorrent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gjh4-fcv3-whpq (OSV record GHSA-gjh4-fcv3-whpq lists affected ranges: npm webtorrent >=0 <0.107.6 (fixed)) - Verified: https://github.com/advisories/GHSA-gjh4-fcv3-whpq (GitHub-reviewed advisory GHSA-gjh4-fcv3-whpq lists affected ranges: npm webtorrent >=0 <0.107.6) Commands are suggestions: review each one before running it.
Loading voting…