Skip to content

← Actionable
High, CVSS 7.3amended

SQL Injection in connect-pg-simple

CVE-2019-15658GHSA-xqh8-5j36-4556

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (connect-pg-simple 6.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2019-15658: 0.98% estimated exploitation activity in the next 30 days; percentile 62.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An unlikely SQL injection if the case of an unsanitized table name input. Patches The user should upgrade to 6.0.1. Due to its low impact a backport has not been made to the 5.x branch. Workarounds If there is no likelihood that the tableName or schemaName options sent to the constructor could be of an unsanitized nature, then no workaround is needed. Else the input could be sanitized and escaped before sending it in. Take note though that such an escaping would need to be removed when upgrading to 6.0.1 or later, to avoid double escaping. References Security issue disclosure For more information If you have any questions or comments about this advisory: Open an issue in voxpelli/node-connect-pg-simple Email maintainer at pelle@kodfabrik.se

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xqh8-5j36-4556

  2. Revision 1 · created ·

    Published from osv record GHSA-xqh8-5j36-4556

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-15658

Advisory: SQL Injection in connect-pg-simple
IDs: CVE-2019-15658, GHSA-xqh8-5j36-4556
Record: https://patchnext.com/advisories/cve-2019-15658 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: connect-pg-simple 6.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm connect-pg-simple: affected < 6.0.1; fixed in 6.0.1

## Suggested inspection (read-only)
- `npm ls connect-pg-simple --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on connect-pg-simple.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xqh8-5j36-4556 (OSV record GHSA-xqh8-5j36-4556 lists affected ranges: npm connect-pg-simple >=0 <6.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-xqh8-5j36-4556 (GitHub-reviewed advisory GHSA-xqh8-5j36-4556 lists affected ranges: npm connect-pg-simple >=0 <6.0.1)

Commands are suggestions: review each one before running it.

Loading voting…