Double free in smallvec
CVE-2019-15551GHSA-mm7v-vpv8-xfc3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (smallvec 0.6.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io smallvec
- Affected
- >= 0.6.5, < 0.6.10
- Fixed in
- 0.6.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mm7v-vpv8-xfc3 lists affected ranges: crates.io smallvec >=0.6.5 <0.6.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-15551: 1.86% estimated exploitation activity in the next 30 days; percentile 79.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Attempting to call grow on a spilled SmallVec with a value equal to the current capacity causes it to free the existing data. This performs a double free immediately and may lead to use-after-free on subsequent accesses to the SmallVec contents. An attacker that controls the value passed to grow may exploit this flaw to obtain memory contents or gain remote code execution.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mm7v-vpv8-xfc3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-15551 Advisory: Double free in smallvec IDs: CVE-2019-15551, GHSA-mm7v-vpv8-xfc3 Record: https://patchnext.com/advisories/cve-2019-15551 (revision 1, source checked 26 Oct 2026, 15:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: smallvec 0.6.10. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io smallvec: affected >= 0.6.5, < 0.6.10; fixed in 0.6.10 ## Suggested inspection (read-only) - crates.io smallvec: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on smallvec. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mm7v-vpv8-xfc3 (GitHub-reviewed advisory GHSA-mm7v-vpv8-xfc3 lists affected ranges: crates.io smallvec >=0.6.5 <0.6.10) Commands are suggestions: review each one before running it.
Loading voting…