Skip to content

← Actionable
High, CVSS 7.5

Out of bounds read in simd-json

CVE-2019-15550GHSA-gwfj-pw2x-h6c2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simd-json 0.1.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io simd-json

    Affected
    >= 0.1.13, < 0.1.15
    Fixed in
    0.1.15

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2019-15550: 1.40% estimated exploitation activity in the next 30 days; percentile 72.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The affected version of this crate did not guard against accessing memory beyond the range of its input data. A pointer cast to read the data into a 256-bit register could lead to a segmentation fault when the end plus the 32 bytes (256 bit) read would overlap into the next page during string parsing. This allows an attacker to eventually crash a service. The flaw was corrected by using a padding buffer for the last read from the input. So that we are we never read over the boundary of the input data.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gwfj-pw2x-h6c2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-15550

Advisory: Out of bounds read in simd-json
IDs: CVE-2019-15550, GHSA-gwfj-pw2x-h6c2
Record: https://patchnext.com/advisories/cve-2019-15550 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simd-json 0.1.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io simd-json: affected >= 0.1.13, < 0.1.15; fixed in 0.1.15

## Suggested inspection (read-only)
- crates.io simd-json: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simd-json.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gwfj-pw2x-h6c2 (GitHub-reviewed advisory GHSA-gwfj-pw2x-h6c2 lists affected ranges: crates.io simd-json >=0.1.13 <0.1.15)

Commands are suggestions: review each one before running it.

Loading voting…