Failure to properly verify ed25519 signatures in libp2p-core
CVE-2019-15545GHSA-4q4x-67hx-5mpg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (libp2p-core 0.8.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io libp2p-core
- Affected
- < 0.8.1
- Fixed in
- 0.8.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4q4x-67hx-5mpg lists affected ranges: crates.io libp2p-core >=0 <0.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2019-15545: 0.77% estimated exploitation activity in the next 30 days; percentile 55.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of this crate did not properly verify ed25519 signatures. Any signature with a correct length was considered valid. This allows an attacker to impersonate any node identity.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4q4x-67hx-5mpg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-15545 Advisory: Failure to properly verify ed25519 signatures in libp2p-core IDs: CVE-2019-15545, GHSA-4q4x-67hx-5mpg Record: https://patchnext.com/advisories/cve-2019-15545 (revision 1, source checked 26 Oct 2026, 15:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: libp2p-core 0.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io libp2p-core: affected < 0.8.1; fixed in 0.8.1 ## Suggested inspection (read-only) - crates.io libp2p-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on libp2p-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4q4x-67hx-5mpg (GitHub-reviewed advisory GHSA-4q4x-67hx-5mpg lists affected ranges: crates.io libp2p-core >=0 <0.8.1) Commands are suggestions: review each one before running it.
Loading voting…