Skip to content

← Actionable
Medium, CVSS 6.1

MantisBT XSS when uploading an attachment

CVE-2019-15539GHSA-p495-jrpq-p66g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mantisbt/mantisbt 2.21.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-15539: 1.17% estimated exploitation activity in the next 30 days; percentile 67.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The projdoceditpage.php Project Documentation feature in MantisBT before 2.21.3 has a stored cross-site scripting (XSS) vulnerability, allowing execution of arbitrary code (if CSP settings permit it) after uploading an attachment with a crafted filename. The code is executed when editing the document's page.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p495-jrpq-p66g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-15539

Advisory: MantisBT XSS when uploading an attachment
IDs: CVE-2019-15539, GHSA-p495-jrpq-p66g
Record: https://patchnext.com/advisories/cve-2019-15539 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mantisbt/mantisbt 2.21.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mantisbt/mantisbt: affected < 2.21.3; fixed in 2.21.3

## Suggested inspection (read-only)
- Packagist mantisbt/mantisbt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mantisbt/mantisbt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p495-jrpq-p66g (GitHub-reviewed advisory GHSA-p495-jrpq-p66g lists affected ranges: Packagist mantisbt/mantisbt >=0 <2.21.3)

Commands are suggestions: review each one before running it.

Loading voting…