Skip to content

← Actionable
Medium, CVSS 6.1amended

Cross-Site Scripting in cyberchef

CVE-2019-15532GHSA-jp6r-xcjj-5h7r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cyberchef 8.31.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-15532: 1.31% estimated exploitation activity in the next 30 days; percentile 70.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of cyberchef prior to 8.31.3 are vulnerable to Cross-Site Scripting. In Text Encoding Brute Force the table rows are created by concatenating the value variable unsanitized in the HTML code. If this variable is controlled by user input it allows attackers to execute arbitrary JavaScript in a victim's browser. Recommendation Upgrade to version 8.31.3 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jp6r-xcjj-5h7r

  2. Revision 1 · created ·

    Published from osv record GHSA-jp6r-xcjj-5h7r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-15532

Advisory: Cross-Site Scripting in cyberchef
IDs: CVE-2019-15532, GHSA-jp6r-xcjj-5h7r
Record: https://patchnext.com/advisories/cve-2019-15532 (revision 2, source checked 26 Oct 2026, 12:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cyberchef 8.31.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm cyberchef: affected < 8.31.3; fixed in 8.31.3

## Suggested inspection (read-only)
- `npm ls cyberchef --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cyberchef.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jp6r-xcjj-5h7r (OSV record GHSA-jp6r-xcjj-5h7r lists affected ranges: npm cyberchef >=0 <8.31.3 (fixed))
- Verified: https://github.com/advisories/GHSA-jp6r-xcjj-5h7r (GitHub-reviewed advisory GHSA-jp6r-xcjj-5h7r lists affected ranges: npm cyberchef >=0 <8.31.3)

Commands are suggestions: review each one before running it.

Loading voting…