Arbitrary File Read in html-pdf
CVE-2019-15138GHSA-x4w5-r546-x9qh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (html-pdf 3.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm html-pdf
- Affected
- < 3.0.1
- Fixed in
- 3.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x4w5-r546-x9qh lists affected ranges: npm html-pdf >=0 <3.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x4w5-r546-x9qh lists affected ranges: npm html-pdf >=0 <3.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2019-15138: 1.83% estimated exploitation activity in the next 30 days; percentile 78.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
All versions of html-pdf are vulnerable to Arbitrary File Read. The package fails to sanitize the HTML input, allowing attackers to exfiltrate server files by supplying malicious HTML code. XHR requests in the HTML code are executed by the server. Input with an XHR request such as request.open("GET","file:///etc/passwd") will result in a PDF document with the contents of /etc/passwd. Recommendation No fix is currently available. There is a mitigation available in the provided reference.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x4w5-r546-x9qh
- Revision 1 · created ·
Published from osv record GHSA-x4w5-r546-x9qh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-15138 Advisory: Arbitrary File Read in html-pdf IDs: CVE-2019-15138, GHSA-x4w5-r546-x9qh Record: https://patchnext.com/advisories/cve-2019-15138 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: html-pdf 3.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm html-pdf: affected < 3.0.1; fixed in 3.0.1 ## Suggested inspection (read-only) - `npm ls html-pdf --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on html-pdf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x4w5-r546-x9qh (OSV record GHSA-x4w5-r546-x9qh lists affected ranges: npm html-pdf >=0 <3.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-x4w5-r546-x9qh (GitHub-reviewed advisory GHSA-x4w5-r546-x9qh lists affected ranges: npm html-pdf >=0 <3.0.1) Commands are suggestions: review each one before running it.
Loading voting…