Skip to content

← Actionable
Medium, CVSS 5.3

Moodle Email media URL tokens were not checking for user status

CVE-2019-14883GHSA-774q-wfcp-vc2q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.7.3, 3.6.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 3.6, < 3.6.7>= 3.7, < 3.7.3
    Fixed in
    3.6.7, 3.7.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2019-14883: 1.09% estimated exploitation activity in the next 30 days; percentile 65.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in Moodle 3.6 before 3.6.7 and 3.7 before 3.7.3, where tokens used to fetch inline atachments in email notifications were not disabled when a user's account was no longer active. Note: to access files, a user would need to know the file path, and their token.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-774q-wfcp-vc2q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-14883

Advisory: Moodle Email media URL tokens were not checking for user status
IDs: CVE-2019-14883, GHSA-774q-wfcp-vc2q
Record: https://patchnext.com/advisories/cve-2019-14883 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.7.3, 3.6.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 3.6, < 3.6.7; >= 3.7, < 3.7.3; fixed in 3.6.7, 3.7.3

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-774q-wfcp-vc2q (GitHub-reviewed advisory GHSA-774q-wfcp-vc2q lists affected ranges: Packagist moodle/moodle >=3.6 =3.7 <3.7.3)

Commands are suggestions: review each one before running it.

Loading voting…