Moodle Oauth 2 Insufficiently Protects Against Compromise
CVE-2019-14880GHSA-rv62-6f56-j83w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.7.3, 3.6.7, 3.5.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 3.7.0, < 3.7.3>= 3.6.0, < 3.6.7>= 3.5.0, < 3.5.9
- Fixed in
- 3.6.7, 3.5.9, 3.7.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rv62-6f56-j83w lists affected ranges: Packagist moodle/moodle >=3.7.0 =3.6.0 =3.5.0 <3.5.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2019-14880: 1.11% estimated exploitation activity in the next 30 days; percentile 65.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in Moodle versions 3.7 before 3.7.3, 3.6 before 3.6.7, 3.5 before 3.5.9 and earlier. OAuth 2 providers who do not verify users' email address changes require additional verification during sign-up to reduce the risk of account compromise.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rv62-6f56-j83w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-14880 Advisory: Moodle Oauth 2 Insufficiently Protects Against Compromise IDs: CVE-2019-14880, GHSA-rv62-6f56-j83w Record: https://patchnext.com/advisories/cve-2019-14880 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.7.3, 3.6.7, 3.5.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 3.7.0, < 3.7.3; >= 3.6.0, < 3.6.7; >= 3.5.0, < 3.5.9; fixed in 3.6.7, 3.5.9, 3.7.3 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rv62-6f56-j83w (GitHub-reviewed advisory GHSA-rv62-6f56-j83w lists affected ranges: Packagist moodle/moodle >=3.7.0 =3.6.0 =3.5.0 <3.5.9) Commands are suggestions: review each one before running it.
Loading voting…