Skip to content

← Actionable
High, CVSS 8.7amended

ecdsa Denial of Service vulnerability in signature verification and signature malleability

CVE-2019-14853GHSA-pwfw-mgfj-7g3g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ecdsa 0.13.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ecdsa

    Affected
    < 0.13.3
    Fixed in
    0.13.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2019-14853: 2.41% estimated exploitation activity in the next 30 days; percentile 84.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

possible DoS in signature verification and signature malleability

Impact Code using `VerifyingKey.verify()` and `VerifyingKey.verify_digest()` may receive exceptions other than the documented `BadSignatureError` when signatures are malformed. If those other exceptions are not caught, they may lead to program termination and thus Denial of Service Code using `VerifyingKey.verify()` and `VerifyingKey.verify_digest()` with `sigdecode` option using `ecdsa.util.sigdecode_der` will accept signatures even if they are not properly formatted DER. This makes the signatures malleable. It impacts only applications that later sign the signatures or verify signatures of signatures, e.g. Bitcoin. All versions between 0.5 and 0.13.2 (inclusive) are thought to be vulnerable. Code before 0.5 may be vulnerable but didn't receive extended analysis to rule this issue out.

Patches The patches have been merged to `master` branch in https://github.com/warner/python-ecdsa/pull/115. The backported…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 1 · created ·

    Published from osv record GHSA-pwfw-mgfj-7g3g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-14853

Advisory: ecdsa Denial of Service vulnerability in signature verification and signature malleability
IDs: CVE-2019-14853, GHSA-pwfw-mgfj-7g3g
Record: https://patchnext.com/advisories/cve-2019-14853 (revision 2, source checked 25 Oct 2026, 04:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ecdsa 0.13.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ecdsa: affected < 0.13.3; fixed in 0.13.3

## Suggested inspection (read-only)
- `python -m pip show ecdsa`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ecdsa.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pwfw-mgfj-7g3g (OSV record GHSA-pwfw-mgfj-7g3g lists affected ranges: PyPI ecdsa >=0 <0.13.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…