Cross-Site Scripting (XSS) in Verdaccio
CVE-2019-14772GHSA-78j5-gcmf-vqc8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (verdaccio 3.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm verdaccio
- Affected
- < 3.12.0
- Fixed in
- 3.12.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-78j5-gcmf-vqc8 lists affected ranges: npm verdaccio >=0 <3.12.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-78j5-gcmf-vqc8 lists affected ranges: npm verdaccio >=0 <3.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-14772: 0.86% estimated exploitation activity in the next 30 days; percentile 58.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? Cross-Site Scripting XSS, malicious packages with content Javascript that might be executed in the User Interface stealing user credentials. Patches Has the problem been patched? What versions should users upgrade to? Users that still using v3 must upgrade to 3.12.0 or those have no problem to migrate to a major version =4.0.0 also fix the issue. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? No, the users must update. References Are there any links users can visit to find out more? https://www.npmjs.com/advisories/832 https://www.npmjs.com/advisories/833 The issue was reported by the NPMJS Security Team For more information If you have any questions or comments about this advisory: Read the Security Policy to find the ways to be in contact with us.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-78j5-gcmf-vqc8
- Revision 1 · created ·
Published from osv record GHSA-78j5-gcmf-vqc8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-14772 Advisory: Cross-Site Scripting (XSS) in Verdaccio IDs: CVE-2019-14772, GHSA-78j5-gcmf-vqc8 Record: https://patchnext.com/advisories/cve-2019-14772 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: verdaccio 3.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm verdaccio: affected < 3.12.0; fixed in 3.12.0 ## Suggested inspection (read-only) - `npm ls verdaccio --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on verdaccio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-78j5-gcmf-vqc8 (OSV record GHSA-78j5-gcmf-vqc8 lists affected ranges: npm verdaccio >=0 <3.12.0 (fixed)) - Verified: https://github.com/advisories/GHSA-78j5-gcmf-vqc8 (GitHub-reviewed advisory GHSA-78j5-gcmf-vqc8 lists affected ranges: npm verdaccio >=0 <3.12.0) Commands are suggestions: review each one before running it.
Loading voting…