Skip to content

← Actionable
Critical, CVSS 9.8

Access of Resource Using Incompatible Type ('Type Confusion') in yourls/yourls

CVE-2019-14537GHSA-vf23-f26f-mjj9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yourls/yourls 1.7.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-14537: 6.14% estimated exploitation activity in the next 30 days; percentile 93.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact YOURLS through 1.7.3 is affected by a type juggling vulnerability in the API component that can result in login bypass. Patches https://github.com/YOURLS/YOURLS/releases/tag/1.7.4 https://github.com/YOURLS/YOURLS/pull/2542 References https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14537 https://github.com/Wocanilo/CVE-2019-14537 For more information If you have any questions or comments about this advisory: Open an issue in YOURLS repository

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vf23-f26f-mjj9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-14537

Advisory: Access of Resource Using Incompatible Type ('Type Confusion') in yourls/yourls
IDs: CVE-2019-14537, GHSA-vf23-f26f-mjj9
Record: https://patchnext.com/advisories/cve-2019-14537 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yourls/yourls 1.7.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist yourls/yourls: affected < 1.7.4; fixed in 1.7.4

## Suggested inspection (read-only)
- Packagist yourls/yourls: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yourls/yourls.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vf23-f26f-mjj9 (GitHub-reviewed advisory GHSA-vf23-f26f-mjj9 lists affected ranges: Packagist yourls/yourls >=0 <1.7.4)

Commands are suggestions: review each one before running it.

Loading voting…