Out-of-bounds Read and Out-of-bounds Write in OpenCV
CVE-2019-14492GHSA-fw99-f933-rgh8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (opencv-python-headless 4.1.1.26, 3.4.7.28; opencv-contrib-python-headless 4.1.1.26, 3.4.7.28; opencv-python 4.1.1.26, 3.4.7.28; opencv-contrib-python 4.1.1.26, 3.4.7.28), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 3.4.6.27>= 4.0.0.21, <= 4.1.0.25
- Fixed in
- 4.1.1.26, 3.4.7.28
PyPI opencv-contrib-python-headless
- Affected
- <= 3.4.6.27>= 4.0.0.21, <= 4.1.0.25
- Fixed in
- 4.1.1.26, 3.4.7.28
PyPI opencv-python
- Affected
- <= 3.4.6.27>= 4.0.0.21, <= 4.1.0.25
- Fixed in
- 4.1.1.26, 3.4.7.28
- Affected
- <= 3.4.6.27>= 4.0.0.21, <= 4.1.0.25
- Fixed in
- 4.1.1.26, 3.4.7.28
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fw99-f933-rgh8 lists affected ranges: PyPI opencv-python >=0 =4.0.0.21 =0 =4.0.0.21 =0 =4.0.0.21 =0 =4.0.0.21 <4.1.1.26 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fw99-f933-rgh8 lists affected ranges: PyPI opencv-python >=0 =4.0.0.21 =0 =4.0.0.21 =0 =4.0.0.21 =0 =4.0.0.21 <=4.1.0.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2019-14492: 3.02% estimated exploitation activity in the next 30 days; percentile 87.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in OpenCV before 3.4.7 and 4.x before 4.1.1 (OpenCV-Python before 3.4.7.28 and 4.x before 4.1.1.26). There is an out of bounds read/write in the function HaarEvaluator::OptFeature::calc in modules/objdetect/src/cascadedetect.hpp, which leads to denial of service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fw99-f933-rgh8
- Revision 1 · created ·
Published from osv record GHSA-fw99-f933-rgh8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-14492 Advisory: Out-of-bounds Read and Out-of-bounds Write in OpenCV IDs: CVE-2019-14492, GHSA-fw99-f933-rgh8 Record: https://patchnext.com/advisories/cve-2019-14492 (revision 2, source checked 26 Oct 2026, 13:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: opencv-python-headless 4.1.1.26, 3.4.7.28; opencv-contrib-python-headless 4.1.1.26, 3.4.7.28; opencv-python 4.1.1.26, 3.4.7.28; opencv-contrib-python 4.1.1.26, 3.4.7.28. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI opencv-python-headless: affected <= 3.4.6.27; >= 4.0.0.21, <= 4.1.0.25; fixed in 4.1.1.26, 3.4.7.28 - PyPI opencv-contrib-python-headless: affected <= 3.4.6.27; >= 4.0.0.21, <= 4.1.0.25; fixed in 4.1.1.26, 3.4.7.28 - PyPI opencv-python: affected <= 3.4.6.27; >= 4.0.0.21, <= 4.1.0.25; fixed in 4.1.1.26, 3.4.7.28 - PyPI opencv-contrib-python: affected <= 3.4.6.27; >= 4.0.0.21, <= 4.1.0.25; fixed in 4.1.1.26, 3.4.7.28 ## Suggested inspection (read-only) - `python -m pip show opencv-python-headless`: prints the installed version. Run with the environment that serves production active. - `python -m pip show opencv-contrib-python-headless`: prints the installed version. Run with the environment that serves production active. - `python -m pip show opencv-python`: prints the installed version. Run with the environment that serves production active. - `python -m pip show opencv-contrib-python`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on opencv-python-headless, opencv-contrib-python-headless, opencv-python, opencv-contrib-python. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fw99-f933-rgh8 (OSV record GHSA-fw99-f933-rgh8 lists affected ranges: PyPI opencv-python >=0 =4.0.0.21 =0 =4.0.0.21 =0 =4.0.0.21 =0 =4.0.0.21 <4.1.1.26 (fixed)) - Verified: https://github.com/advisories/GHSA-fw99-f933-rgh8 (GitHub-reviewed advisory GHSA-fw99-f933-rgh8 lists affected ranges: PyPI opencv-python >=0 =4.0.0.21 =0 =4.0.0.21 =0 =4.0.0.21 =0 =4.0.0.21 <=4.1.0.25) Commands are suggestions: review each one before running it.
Loading voting…