OpenStack Nova Server Resource Faults Leak External Exception Details
CVE-2019-14433GHSA-pg64-r7rr-phv8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nova 19.0.2, 18.2.2, 17.0.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI nova
- Affected
- < 17.0.12>= 18.0.0, < 18.2.2>= 19.0.0, < 19.0.2
- Fixed in
- 19.0.2, 17.0.12, 18.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pg64-r7rr-phv8 lists affected ranges: PyPI nova >=0 =18.0.0 =19.0.0 <19.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pg64-r7rr-phv8 lists affected ranges: PyPI nova >=0 =18.0.0 =19.0.0 <19.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2019-14433: 1.94% estimated exploitation activity in the next 30 days; percentile 80.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in OpenStack Nova before 17.0.12, 18.x before 18.2.2, and 19.x before 19.0.2. If an API request from an authenticated user ends in a fault condition due to an external exception, details of the underlying environment may be leaked in the response, and could include sensitive configuration or other data.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pg64-r7rr-phv8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pg64-r7rr-phv8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-14433 Advisory: OpenStack Nova Server Resource Faults Leak External Exception Details IDs: CVE-2019-14433, GHSA-pg64-r7rr-phv8 Record: https://patchnext.com/advisories/cve-2019-14433 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nova 19.0.2, 18.2.2, 17.0.12. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nova: affected < 17.0.12; >= 18.0.0, < 18.2.2; >= 19.0.0, < 19.0.2; fixed in 19.0.2, 17.0.12, 18.2.2 ## Suggested inspection (read-only) - `python -m pip show nova`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nova. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pg64-r7rr-phv8 (OSV record GHSA-pg64-r7rr-phv8 lists affected ranges: PyPI nova >=0 =18.0.0 =19.0.0 <19.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-pg64-r7rr-phv8 (GitHub-reviewed advisory GHSA-pg64-r7rr-phv8 lists affected ranges: PyPI nova >=0 =18.0.0 =19.0.0 <19.0.2) Commands are suggestions: review each one before running it.
Loading voting…