python-engineio vulnerable to Cross-Site Request Forgery (CSRF)
CVE-2019-13611GHSA-j3jp-gvr5-7hwq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-engineio 3.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI python-engineio
- Affected
- <= 3.8.2
- Fixed in
- 3.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j3jp-gvr5-7hwq lists affected ranges: PyPI python-engineio >=0 <3.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3jp-gvr5-7hwq lists affected ranges: PyPI python-engineio >=0 <=3.8.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2019-13611: 0.85% estimated exploitation activity in the next 30 days; percentile 58.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
WebSocket cross-origin vulnerability Impact This is a Cross-Site Request Forgery (CSRF) vulnerability. It affects Socket.IO and Engine.IO web servers that authenticate clients using cookies. Patches python-engineio version 3.9.0 patches this vulnerability by adding server-side Origin header checks. Workarounds Do not use cookies for client authentication, or else add a CSRF token to the connection URL. References https://www.owasp.org/index.php/Cross-SiteRequestForgery(CSRF) https://www.christian-schneider.net/CrossSiteWebSocketHijacking.html For more information If you have any questions or comments about this advisory: Open an issue in python-engineio
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j3jp-gvr5-7hwq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-j3jp-gvr5-7hwq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-13611 Advisory: python-engineio vulnerable to Cross-Site Request Forgery (CSRF) IDs: CVE-2019-13611, GHSA-j3jp-gvr5-7hwq Record: https://patchnext.com/advisories/cve-2019-13611 (revision 3, source checked 26 Oct 2026, 13:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: python-engineio 3.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI python-engineio: affected <= 3.8.2; fixed in 3.9.0 ## Suggested inspection (read-only) - `python -m pip show python-engineio`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on python-engineio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j3jp-gvr5-7hwq (OSV record GHSA-j3jp-gvr5-7hwq lists affected ranges: PyPI python-engineio >=0 <3.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-j3jp-gvr5-7hwq (GitHub-reviewed advisory GHSA-j3jp-gvr5-7hwq lists affected ranges: PyPI python-engineio >=0 <=3.8.2) Commands are suggestions: review each one before running it.
Loading voting…