Skip to content

← Actionable
High, CVSS 8.8amended

Mirumee Saleor CSRF Protection Disabled

CVE-2019-13594GHSA-fgjh-x3f8-8gmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (saleor 2.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI saleor

    Affected
    >= 2.7.0, <= 2.7.0
    Fixed in
    2.8.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-13594: 0.62% estimated exploitation activity in the next 30 days; percentile 49.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Mirumee Saleor 2.7.0 (fixed in 2.8.0), CSRF protection middleware was accidentally disabled, which allowed attackers to send a POST request without a valid CSRF token and be accepted by the server.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fgjh-x3f8-8gmh

  2. Revision 1 · created ·

    Published from osv record GHSA-fgjh-x3f8-8gmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-13594

Advisory: Mirumee Saleor CSRF Protection Disabled
IDs: CVE-2019-13594, GHSA-fgjh-x3f8-8gmh
Record: https://patchnext.com/advisories/cve-2019-13594 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: saleor 2.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI saleor: affected >= 2.7.0, <= 2.7.0; fixed in 2.8.0

## Suggested inspection (read-only)
- `python -m pip show saleor`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on saleor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fgjh-x3f8-8gmh (OSV record GHSA-fgjh-x3f8-8gmh lists affected ranges: PyPI saleor >=2.7.0 <2.8.0 (fixed))
- Verified: https://github.com/advisories/GHSA-fgjh-x3f8-8gmh (GitHub-reviewed advisory GHSA-fgjh-x3f8-8gmh lists affected ranges: PyPI saleor >=2.7.0 <=2.7.0)

Commands are suggestions: review each one before running it.

Loading voting…