Skip to content

← Actionable
Medium, CVSS 5.3

field_test gem contains injection vulnerability

CVE-2019-13146GHSA-wg9m-gw3h-hg83

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (field_test 0.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems field_test

    Affected
    >= 0.3.0, <= 0.3.0
    Fixed in
    0.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2019-13146: 1.45% estimated exploitation activity in the next 30 days; percentile 73.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The fieldtest gem 0.3.0 for Ruby has unvalidated input. A method call that is expected to return a value from a certain set of inputs can be made to return any input, which can be dangerous depending on how applications use it. If an application treats arbitrary variants as trusted, this can lead to a variety of potential vulnerabilities like SQL injection or cross-site scripting (XSS).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wg9m-gw3h-hg83

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-13146

Advisory: field_test gem contains injection vulnerability
IDs: CVE-2019-13146, GHSA-wg9m-gw3h-hg83
Record: https://patchnext.com/advisories/cve-2019-13146 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: field_test 0.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems field_test: affected >= 0.3.0, <= 0.3.0; fixed in 0.3.1

## Suggested inspection (read-only)
- RubyGems field_test: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on field_test.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wg9m-gw3h-hg83 (GitHub-reviewed advisory GHSA-wg9m-gw3h-hg83 lists affected ranges: RubyGems field_test >=0.3.0 <=0.3.0)

Commands are suggestions: review each one before running it.

Loading voting…