Skip to content

← Actionable
Medium, CVSS 6.1amended

mxGraph vulnerable to cross-site scripting in color field

CVE-2019-13127GHSA-xm59-jvxm-cp3v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mxgraph 4.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mxgraph

    Affected
    <= 4.0.0
    Fixed in
    4.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-13127: 1.50% estimated exploitation activity in the next 30 days; percentile 74.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

mxGraph through 4.0.0, related to the draw.io Diagrams plugin before 8.3.14 for Confluence and other products, is vulnerable to cross-site scripting. draw.io Diagrams allows the creation and editing of draw.io-based diagrams in Confluence. Among other things, it allows to set the background color of text displayed in the diagram. The color provided by the user is notproperly sanitized, leading to HTML and JavaScript code to be displayed "as it is" to visitors of the page. This allows attackers to execute JavaScript code in the context of the visitor's browser and session and to e.g. run Confluence command under the visitor's user or attack the visitor's browser. Proof of Concept (PoC): 1. Create a new draw.io Diagram, add an element and edit its background color and enter some text to the element 2. Enter the following "color": onMouseOver=alert(1) a= 3. Save and view the resulting diagram, moving your mouse over the text

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xm59-jvxm-cp3v

  2. Revision 1 · created ·

    Published from osv record GHSA-xm59-jvxm-cp3v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-13127

Advisory: mxGraph vulnerable to cross-site scripting in color field
IDs: CVE-2019-13127, GHSA-xm59-jvxm-cp3v
Record: https://patchnext.com/advisories/cve-2019-13127 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mxgraph 4.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mxgraph: affected <= 4.0.0; fixed in 4.0.1

## Suggested inspection (read-only)
- `npm ls mxgraph --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mxgraph.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xm59-jvxm-cp3v (OSV record GHSA-xm59-jvxm-cp3v lists affected ranges: npm mxgraph >=0 <4.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-xm59-jvxm-cp3v (GitHub-reviewed advisory GHSA-xm59-jvxm-cp3v lists affected ranges: npm mxgraph >=0 <=4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…