Skip to content

← Actionable
Critical, CVSS 9.1amended

Improper Certificate Validation in Twisted

CVE-2019-12855GHSA-65rm-h285-5cc5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (twisted 19.7.0rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI twisted

    Affected
    < 19.7.0rc1
    Fixed in
    19.7.0rc1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2019-12855: 1.81% estimated exploitation activity in the next 30 days; percentile 78.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In words.protocols.jabber.xmlstream in Twisted through 19.2.1, XMPP support did not verify certificates when used with TLS, allowing an attacker to MITM connections.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-65rm-h285-5cc5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-65rm-h285-5cc5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-12855

Advisory: Improper Certificate Validation in Twisted
IDs: CVE-2019-12855, GHSA-65rm-h285-5cc5
Record: https://patchnext.com/advisories/cve-2019-12855 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: twisted 19.7.0rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI twisted: affected < 19.7.0rc1; fixed in 19.7.0rc1

## Suggested inspection (read-only)
- `python -m pip show twisted`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on twisted.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-65rm-h285-5cc5 (OSV record GHSA-65rm-h285-5cc5 lists affected ranges: PyPI twisted >=0 <19.7.0rc1 (fixed))
- Verified: https://github.com/advisories/GHSA-65rm-h285-5cc5 (GitHub-reviewed advisory GHSA-65rm-h285-5cc5 lists affected ranges: PyPI twisted >=0 <19.7.0rc1)

Commands are suggestions: review each one before running it.

Loading voting…