TYPO3 Vulnerable to Insecure Deserialization
CVE-2019-12747GHSA-86hp-xrhj-fhpq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 9.5.8, 8.7.27; typo3/cms 9.5.8, 8.7.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist typo3/cms-core
- Affected
- >= 8.0.0, < 8.7.27>= 9.0.0, < 9.5.8
- Fixed in
- 8.7.27, 9.5.8
Packagist typo3/cms
- Affected
- >= 8.0.0, < 8.7.27>= 9.0.0, < 9.5.8
- Fixed in
- 8.7.27, 9.5.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-86hp-xrhj-fhpq lists affected ranges: Packagist typo3/cms-core >=8.0.0 =9.0.0 =8.0.0 =9.0.0 <9.5.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-12747: 1.53% estimated exploitation activity in the next 30 days; percentile 74.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TYPO3 8.x through 8.7.26 and 9.x through 9.5.7 allows Deserialization of Untrusted Data.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-86hp-xrhj-fhpq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-12747 Advisory: TYPO3 Vulnerable to Insecure Deserialization IDs: CVE-2019-12747, GHSA-86hp-xrhj-fhpq Record: https://patchnext.com/advisories/cve-2019-12747 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 9.5.8, 8.7.27; typo3/cms 9.5.8, 8.7.27. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist typo3/cms-core: affected >= 8.0.0, < 8.7.27; >= 9.0.0, < 9.5.8; fixed in 8.7.27, 9.5.8 - Packagist typo3/cms: affected >= 8.0.0, < 8.7.27; >= 9.0.0, < 9.5.8; fixed in 8.7.27, 9.5.8 ## Suggested inspection (read-only) - Packagist typo3/cms-core: check the installed version with your package manager. - Packagist typo3/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on typo3/cms-core, typo3/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-86hp-xrhj-fhpq (GitHub-reviewed advisory GHSA-86hp-xrhj-fhpq lists affected ranges: Packagist typo3/cms-core >=8.0.0 =9.0.0 =8.0.0 =9.0.0 <9.5.8) Commands are suggestions: review each one before running it.
Loading voting…