Skip to content

← Actionable
Medium, CVSS 6.1

Cross-site Scripting in HAPI FHIR

CVE-2019-12741GHSA-52mh-p2m2-w625

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ca.uhn.hapi.fhir:hapi-fhir-base 3.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-12741: 1.27% estimated exploitation activity in the next 30 days; percentile 69.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

XSS exists in the HAPI FHIR testpage overlay module of the HAPI FHIR library before 3.8.0. The attack involves unsanitized HTTP parameters being output in a form page, allowing attackers to leak cookies and other sensitive information from ca/uhn/fhir/to/BaseController.java via a specially crafted URL. (This module is not generally used in production systems so the attack surface is expected to be low, but affected systems are recommended to upgrade immediately.)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-52mh-p2m2-w625

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-12741

Advisory: Cross-site Scripting in HAPI FHIR
IDs: CVE-2019-12741, GHSA-52mh-p2m2-w625
Record: https://patchnext.com/advisories/cve-2019-12741 (revision 1, source checked 26 Oct 2026, 16:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ca.uhn.hapi.fhir:hapi-fhir-base 3.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven ca.uhn.hapi.fhir:hapi-fhir-base: affected < 3.8.0; fixed in 3.8.0

## Suggested inspection (read-only)
- Maven ca.uhn.hapi.fhir:hapi-fhir-base: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ca.uhn.hapi.fhir:hapi-fhir-base.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-52mh-p2m2-w625 (GitHub-reviewed advisory GHSA-52mh-p2m2-w625 lists affected ranges: Maven ca.uhn.hapi.fhir:hapi-fhir-base >=0 <3.8.0)

Commands are suggestions: review each one before running it.

Loading voting…