Apache Airflow vulnerable to XSS and local file disclosure
CVE-2019-12417GHSA-q3p4-gw7r-wqjc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (airflow 1.10.6; apache-airflow 1.10.6rc1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI airflow
- Affected
- < 1.10.6
- Fixed in
- 1.10.6
PyPI apache-airflow
- Affected
- < 1.10.6rc1
- Fixed in
- 1.10.6rc1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q3p4-gw7r-wqjc lists affected ranges: PyPI airflow >=0 <1.10.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2019-216 lists affected ranges: PyPI apache-airflow >=0 <1.10.6rc1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q3p4-gw7r-wqjc lists affected ranges: PyPI airflow >=0 <1.10.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2019-12417: 1.28% estimated exploitation activity in the next 30 days; percentile 69.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views. This also presented a Local File Disclosure vulnerability to any file readable by the webserver process.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-q3p4-gw7r-wqjc
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record PYSEC-2019-216
- Revision 1 · created ·
Published from osv record GHSA-q3p4-gw7r-wqjc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-12417 Advisory: Apache Airflow vulnerable to XSS and local file disclosure IDs: CVE-2019-12417, GHSA-q3p4-gw7r-wqjc Record: https://patchnext.com/advisories/cve-2019-12417 (revision 4, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: airflow 1.10.6; apache-airflow 1.10.6rc1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI airflow: affected < 1.10.6; fixed in 1.10.6 - PyPI apache-airflow: affected < 1.10.6rc1; fixed in 1.10.6rc1 ## Suggested inspection (read-only) - `python -m pip show airflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on airflow, apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q3p4-gw7r-wqjc (OSV record GHSA-q3p4-gw7r-wqjc lists affected ranges: PyPI airflow >=0 <1.10.6 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2019-216 (OSV record PYSEC-2019-216 lists affected ranges: PyPI apache-airflow >=0 <1.10.6rc1 (fixed)) - Verified: https://github.com/advisories/GHSA-q3p4-gw7r-wqjc (GitHub-reviewed advisory GHSA-q3p4-gw7r-wqjc lists affected ranges: PyPI airflow >=0 <1.10.6) Commands are suggestions: review each one before running it.
Loading voting…