Skip to content

← Actionable
High, CVSS 8.7amended

Missing Initialization of Resource in Apache Arrow

CVE-2019-12410GHSA-cjw4-2w9r-r8mv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyarrow 0.15.1; red-arrow 0.15.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyarrow

    Affected
    >= 0.12.0, < 0.15.1
    Fixed in
    0.15.1
  • RubyGems red-arrow

    Affected
    >= 0.12.0, < 0.15.1
    Fixed in
    0.15.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2019-12410: 4.61% estimated exploitation activity in the next 30 days; percentile 91.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

While investigating UBSAN errors in https://github.com/apache/arrow/pull/5365 it was discovered Apache Arrow versions 0.12.0 to 0.14.1, left memory Array data uninitialized when reading RLE null data from parquet. This affected the C++, Python, Ruby and R implementations. The uninitialized memory could potentially be shared if are transmitted over the wire (for instance with Flight) or persisted in the streaming IPC and file formats.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cjw4-2w9r-r8mv

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cjw4-2w9r-r8mv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-12410

Advisory: Missing Initialization of Resource in Apache Arrow
IDs: CVE-2019-12410, GHSA-cjw4-2w9r-r8mv
Record: https://patchnext.com/advisories/cve-2019-12410 (revision 3, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyarrow 0.15.1; red-arrow 0.15.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyarrow: affected >= 0.12.0, < 0.15.1; fixed in 0.15.1
- RubyGems red-arrow: affected >= 0.12.0, < 0.15.1; fixed in 0.15.1

## Suggested inspection (read-only)
- `python -m pip show pyarrow`: prints the installed version. Run with the environment that serves production active.
- RubyGems red-arrow: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyarrow, red-arrow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cjw4-2w9r-r8mv (OSV record GHSA-cjw4-2w9r-r8mv lists affected ranges: PyPI pyarrow >=0.12.0 =0.12.0 <0.15.1 (fixed))
- Verified: https://github.com/advisories/GHSA-cjw4-2w9r-r8mv (GitHub-reviewed advisory GHSA-cjw4-2w9r-r8mv lists affected ranges: RubyGems red-arrow >=0.12.0 =0.12.0 <0.15.1)

Commands are suggestions: review each one before running it.

Loading voting…