Skip to content

← Actionable
Critical, CVSS 9.8

Unrestricted upload of file with dangerous type in Apache Solr

CVE-2019-12409GHSA-2289-pqfq-6wx7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr-core 8.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-12409: 21.61% estimated exploitation activity in the next 30 days; percentile 97.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The 8.1.1 and 8.2.0 releases of Apache Solr contain an insecure setting for the ENABLEREMOTEJMXOPTS configuration option in the default solr.in.sh configuration file shipping with Solr. If you use the default solr.in.sh file from the affected releases, then JMX monitoring will be enabled and exposed on RMIPORT (default=18983), without any authentication. If this port is opened for inbound traffic in your firewall, then anyone with network access to your Solr nodes will be able to access JMX, which may in turn allow them to upload malicious code for execution on the Solr server.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2289-pqfq-6wx7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-12409

Advisory: Unrestricted upload of file with dangerous type in Apache Solr
IDs: CVE-2019-12409, GHSA-2289-pqfq-6wx7
Record: https://patchnext.com/advisories/cve-2019-12409 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr-core 8.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.solr:solr-core: affected >= 8.1.1, <= 8.2.0; fixed in 8.3.0

## Suggested inspection (read-only)
- Maven org.apache.solr:solr-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.solr:solr-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2289-pqfq-6wx7 (GitHub-reviewed advisory GHSA-2289-pqfq-6wx7 lists affected ranges: Maven org.apache.solr:solr-core >=8.1.1 <=8.2.0)

Commands are suggestions: review each one before running it.

Loading voting…