Missing Initialization of Resource in Apache Arrow
CVE-2019-12408GHSA-8cw2-jv5c-c825
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyarrow 0.15.1; red-arrow 0.15.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8cw2-jv5c-c825 lists affected ranges: PyPI pyarrow >=0.14.0 =0.14.0 <0.15.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8cw2-jv5c-c825 lists affected ranges: RubyGems red-arrow >=0.14.0 =0.14.0 <0.15.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2019-12408: 3.25% estimated exploitation activity in the next 30 days; percentile 88.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
It was discovered that the C++ implementation (which underlies the R, Python and Ruby implementations) of Apache Arrow 0.14.0 to 0.14.1 had a uninitialized memory bug when building arrays with null values in some cases. This can lead to uninitialized memory being unintentionally shared if Arrow Arrays are transmitted over the wire (for instance with Flight) or persisted in the streaming IPC and file formats.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8cw2-jv5c-c825
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8cw2-jv5c-c825
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-12408 Advisory: Missing Initialization of Resource in Apache Arrow IDs: CVE-2019-12408, GHSA-8cw2-jv5c-c825 Record: https://patchnext.com/advisories/cve-2019-12408 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pyarrow 0.15.1; red-arrow 0.15.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pyarrow: affected >= 0.14.0, < 0.15.1; fixed in 0.15.1 - RubyGems red-arrow: affected >= 0.14.0, < 0.15.1; fixed in 0.15.1 ## Suggested inspection (read-only) - `python -m pip show pyarrow`: prints the installed version. Run with the environment that serves production active. - RubyGems red-arrow: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pyarrow, red-arrow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8cw2-jv5c-c825 (OSV record GHSA-8cw2-jv5c-c825 lists affected ranges: PyPI pyarrow >=0.14.0 =0.14.0 <0.15.1 (fixed)) - Verified: https://github.com/advisories/GHSA-8cw2-jv5c-c825 (GitHub-reviewed advisory GHSA-8cw2-jv5c-c825 lists affected ranges: RubyGems red-arrow >=0.14.0 =0.14.0 <0.15.1) Commands are suggestions: review each one before running it.
Loading voting…