Skip to content

← Actionable
High, CVSS 7.5

Denial of Service in Apache Commons Compress

CVE-2019-12402GHSA-53x6-4x5p-rrvv

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.github.1tchy.java9modular.org.apache.commons:commons-compress

    Affected
    >= 1.18.1, <= 1.18.1
    Fixed in
    no fixed version recorded
  • Maven org.apache.commons:commons-compress

    Affected
    >= 1.15, < 1.19
    Fixed in
    1.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2019-12402: 16.16% estimated exploitation activity in the next 30 days; percentile 96.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The file name encoding algorithm used internally in Apache Commons Compress 1.15 to 1.18 can get into an infinite loop when faced with specially crafted inputs. This can lead to a denial of service attack if an attacker can choose the file names inside of an archive created by Compress.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-53x6-4x5p-rrvv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-12402

Advisory: Denial of Service in Apache Commons Compress
IDs: CVE-2019-12402, GHSA-53x6-4x5p-rrvv
Record: https://patchnext.com/advisories/cve-2019-12402 (revision 1, source checked 26 Oct 2026, 16:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.commons:commons-compress 1.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.github.1tchy.java9modular.org.apache.commons:commons-compress: affected >= 1.18.1, <= 1.18.1
- Maven org.apache.commons:commons-compress: affected >= 1.15, < 1.19; fixed in 1.19

## Suggested inspection (read-only)
- Maven io.github.1tchy.java9modular.org.apache.commons:commons-compress: check the installed version with your package manager.
- Maven org.apache.commons:commons-compress: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.github.1tchy.java9modular.org.apache.commons:commons-compress, org.apache.commons:commons-compress.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-53x6-4x5p-rrvv (GitHub-reviewed advisory GHSA-53x6-4x5p-rrvv lists affected ranges: Maven org.apache.commons:commons-compress >=1.15 =1.18.1 <=1.18.1)

Commands are suggestions: review each one before running it.

Loading voting…